18 нояб. 2011 г.

FAQ: Как заставить работать плагины на OIM 11.1.1.5, созданные ранее для OIM 11.1.1.3

Short intro: here you can find solution to common problem - migrating plugins from OIM 11.1.1.3.X to OIM 11.1.1.5.X.

Q: Я мигрирую конфигурацию OIM с версии 11.1.1.3 на 11.1.1.5, мои плагины для обработки атрибутов пользователя успешно устанавливаются, присутствуют в соответствующих таблицах PLUGINS, но не вызываются системой.

A: В версии OIM 11.1.1.5 поменялся заголовок для загрузки подключаемых модулей (плагинов) в качестве обработчиков событий (Event Handlers). Обратите внимание на п. 8.2.1 OIM 11g Development Guide, где приведен правильный заголовок. Файлы EventHandlers.xml со старвм заголовком будут грузиться в MDS, но не будут видны OIM.


2 комментария:

  1. Що за EventHandlers.xml?

    ОтветитьУдалить
  2. Описание, когда именно (в каком Plugin Point) должен вызываться плагин...

    ОтветитьУдалить