14 мая 2012 г.

(Update) Лицензирование коннекторов к SAP

Short intro: here you can find OIM connector for SAP licensing in the context of the new SAP User Management Engine Connector.

Q: В GPL от 26.04.2012 в сноске 22 указаны следующие коннекторы к SAP: SAP Enterprise Applications, SAP Enterprise Portal. С другой стороны, в списке коннекторов я вижу следующие: SAP Employee Reconciliation, SAP User Management Engine, SAP User Management. Какие доступные для загрузки коннекторы к какой лицензии относятся? Или каждый загружаемый коннектор надо лицензировать отдельно?

















A: Когда-то я выкладывал здесь матрицу коннекторов, "OIM Connectors: License to Connector Package Mapping", т.е. какие коннекторы требуется лицензировать в зависимости от требуемой функциональности.

В настоящий момент имеются два типа лицензий на коннектор к SAP и три физических коннектора, доступных на странице загрузки коннекторов - SAP User Management (SAP UM), SAP Employee Reconciliation (SAP ER), SAP User Management Engine (SAP UME). Лицензии покрывают коннекторы, доступные для загрузки следующим образом:

SAP Enterprise Applications  - SAP UM и SAP ER.
SAP Enterprise Portal - SAP UME.

Давайте попробуем теперь разобраться, какую лицензию нужно приобретать в зависимости от используемого модуля SAP.


1. Стэк продуктов на основе ABAP (примеры продуктов показаны ниже) требует коннектора SAP UM и лицензии SAP Enterprise Applications:

SAP Finance                           SAP ECC 6.0  EHP4             
SAP APO                               SAP SCM 7.0                        
SAP TM                                 SAP Netweaver 7.0 EHP1    
SAP Manufacturing                 SAP ECC 6.0                         
SAP BW                                SAP Netweaver 7.0 EHP1    

2. Заказчик конфигурирует модуль SAP на основе ABAP (например, SAP Finance) вместе с Enterprise Portal. Т.е. при логине в Enterprise Portal SAP сможет аутентифицировать пользователя в ABAP-источнике данных. Когда пользователь создается в Enterprise Portal, он автоматически становится доступен в ABAP-модуле (SAP Finance в данном примере). В этом случае можно использовать коннектор SAP UME под лицензией SAP Enterprise Portal для управления пользователями в ABAP-модулях через портал, а IT Resource будет настроен только на портал.

Но в этом случае будет ограничение - вы сможете использовать только атрибуты UME SAP Enterprise Portal для предоставления доступа, и в случае, если вы захотите управлять другими атрибутами доступа в ABAP-модули SAP, вам потребуется применить коннектор SAP UM под лицензией SAP Enterprise Applications.

3. Далее приведены выдержки из соответствующей документации по коннекторам.

Support matrix for SAP UME is documented at
http://docs.oracle.com/cd/E22999_01/doc.111/e25327/intro.htm#BABCAGFG

Target system

The target system can be one of the following:

    * SAP User Management Engine running on SAP NetWeaver '04 SPS 14 or later
    * SAP User Management Engine running on SAP NetWeaver 7.0 SPS 05 or later

Note: If you install an SAP application in Java stack, such as SAP Enterprise Portal, then the connector can connect to SAP User Management Engine (UME) of the application.

If you install an SAP application, such as SAP BW or SAP SRM, in ABAP stack, then you must configure SAP Enterprise Portal against SAP UME of the application. See the respective target system documentation for information about this configuration.

If you install an SAP application, such as SAP PI, in dual stack (ABAP and Java), then the connector can connect to SAP UME of the application. However, the limitations of the ABAP data source are applicable.

Support matrix for SAP UM is at
http://docs.oracle.com/cd/E11223_01/doc.910/e11212/intro.htm#BABCAGFG

Target systems

The target system can be any one of the following:

    * SAP R/3 4.7 SP 45 (running on WAS 6.20) BASIS SP 48 or later
    * mySAP ERP 2004 (ECC 5.0 running on WAS 6.40) BASIS SP 22 or later
    * mySAP ERP 2005 (ECC 6.0 running on WAS 7.00) BASIS SP 13 or later

Note: From version 6.40 onward, SAP WAS is also known as "SAP NetWeaver."

In general:

    * SAP applications installed on the ABAP stack are supported.
    * Applications installed on the JAVA stack are not supported.
    * Some SAP applications can be installed on the ABAP+JAVA stack. While installing such an application, you specify either ABAP or JAVA as the data source. The connector supports SAP applications that use the ABAP data source.


Support matrix for SAP ER is at
http://docs.oracle.com/cd/E11223_01/doc.910/e11210/intro.htm#CIAGEGAA

Target system
   
The target system can be any one of the following:

    * SAP R/3 4.7 SP 45 (running on WAS 6.20) BASIS SP 48 or later
    * mySAP ERP 2004 (ECC 5.0 running on WAS 6.40) BASIS SP 22 or later
    * mySAP ERP 2005 (ECC 6.0 running on WAS 7.00) BASIS SP 13 or later

Note: From version 6.40 onward, SAP WAS is also known as "SAP NetWeaver."

Комментариев нет:

Отправить комментарий